System Requirements Check

for Test-takers

Prior to your exam, it is important to make sure that your device meets Examity’s online proctoring requirements. 

To verify your system requirements, you will first need to confirm which version of the Examity platform you are using. Please take a look at the images below and identify the one that matches your instance of Examity. You can then see a list of necessary requirements, along with the option to perform a system check.

Examity Classic

The New Examity Platform 

Classic Requirements

  • Operating System: macOS X 10.5 or higher, Windows Vista or higher. Examity does not support Linux or Chrome OS 
  • Browser: Google Chrome or Firefox – please disable your pop-up blocker.  
  • Hardware: Desktop or laptop (tablets, Chromebooks, and mobile are not supported)
    – Built-in or external webcam
    – Built-in or external microphone
    – Built-in or external speakers
  • Internet: An upload and download speed of 2Mbps. Hot spots are not recommended

New Platform Requirements

  • Operating System: macOS X 10.5 or higher, Windows Vista or higher, ChromeOS. Examity does not support Linux
  • Browser: Google Chrome – please disable your pop-up blocker.
  • Hardware: Desktop, laptop, or Chromebook (tablets and mobile are not supported)
    – Built-in or external webcam
    – Built-in or external microphone
    – Built-in or external speakers
  • Internet: An upload and download speed of 2Mbps. Hot spots are not recommended